Dear Valued Client,
 
You may already heard about the Heartbleed bug that has been a hot topic in
the news today. The bug involves a serious vulnerability in OpenSSL
protocol was discovered and nicknamed Heartbleed. We would like to assure
you that all our servers has been patched and we have no security breach
reported.

The Heartbleed Bug allows stealing the information protected by the SSL/TLS
encryption used to secure emails, cpanel, IM or any SSL based encryption in
the Internet. This provides security and privacy over the Internet for
applications that you use. This allows shady users to eavesdrop on
communications, steal data directly from the services and users and to
impersonate services and users. It is assumed that 66% of all websites
across the Internet are affected.

This bug has shown that in some cases usernames, passwords and other
protective data entered on affected sites and services can be easily
compromised.
 
It has been our pride to implement security policies that protects our
clients from know vulnerabilities and bugs.

Though our servers has been patched with the April 7 OpenSSL fix, it is
still advisable that you change any of your existing passwords that access
cpanel, email and any password you might be using. Prevention is still
better than cure.

If you need more information about the Heartbleed bug, you may visit this
website www.heartbleed.com or email us.

Friday, April 11, 2014





« Back